cancel
Showing results for 
Search instead for 
Did you mean: 
Stadia Player
Stadia Player

Stadia Controller only connects to stadia.com via Chrome once

Once I have connected the Stadia controller to stadia.com via Chrome, after I am done playing and the controller turns off, Chrome will no longer recognize it. I turn the controller on, open stadia.com in Chrome, click the stadia.com controller button, and enter the button sequence that appears on the controller. The controller vibrates twice, as it normally would when connected, but stadia.com on Chrome does not show that it is connected. After about ten seconds, the controller turns itself off again.

I can use an Xbox controller, but the latency hurts the gameplay in the kinds of games I like to play (action and racing games, mostly). It is considerably better with the Stadia controller (most of the time).

I have a surprisingly reliable 300 Mbps Comcast Xfinity internet connection. My computer is connected to my gateway via wired ethernet. My stadia controller is connected to the same network reported in Windows. My gateway has two Wifi networks, 2.3 GHz and 5 GHz. I normally have the controller configured for the 5 GHz network, but I have tried it with the 2.3 GHz network, and the same thing happens. I am not using a VPN. I have tried connecting via an incognito window. I have tried deleting stadia.com site information using Chrome settings. I have tried logging out of Google and back in. I have no extensions installed in Chrome, and default Chrome settings and flags.

I have even set up port forwarding to my PC, TCP and UDP ports 44700-44899, as seen in a message I found somewhere. Sorry, don't remember where. Doesn't have any effect anyway.

After a lot of experimentation, I discovered the following sequence seems to get stadia.com to recognize the controller in Chrome:

  1. Sign in to stadia.com on Chrome
  2. Install Stadia as a Chrome app
  3. Run the Stadia Chrome app (usually happens automatically when connected)
  4. Uninstall the Stadia Chrome app, including the option to remove all stadia.com data
  5. Sign in to stadia.com on Chrome. This includes signing in to Google again, using two-factor authentication.
  6. Connect the controller to stadia.com

OR, I can reboot my PC, because it always works the first time after a reboot.

I do not have this problem using the Stadia controller with the Android app on my Pixel 2. I don't have a Chromecast Ultra, so I don't know what might happen if I tried connecting to a TV.

This did not happen when I first got the Stadia controller. I remember having occasional connection problems, but I don't remember when they started.

I have tried contacting Stadia support, and the chat support person was singularly unhelpful. They ran me through a script which included obvious steps that I had already done. In the end, they had me deactivate an unrelated VPN option in windows, despite the fact that I told them I was not using a VPN. They somewhat hastily signed off after having me reboot my PC and successfully connecting, despite the fact that I had told them it always works after a reboot.

Obviously I don't want to have to go through all that crap (or reboot) every time I want to play a game. I'd love to continue using Stadia, in fact I've purchased several games, but not with the controller acting like this.

0 Kudos
0 Replies