cancel
Showing results for 
Search instead for 
Did you mean: 

Stadia Controller Won't Link with Chrome Browser - Help!

The controllers (I have more than one and none are working) are no longer linking to my stadia account through the chrome web browser. I put in the code listed in the browser when you click on the controller icon in the upper-right of the screen and it registers on the controller, but does not actually link to the chrome browser. I have done this every day for two weeks and it has worked fine until today. I tried it with two different controllers, both fully charged, and I get the same result.

0 Kudos
2 Replies
Stadia Guide
Stadia Guide

Hey @Colt_Burkhardt,

sorry to hear you encountered issues now to connect your controllers to Stadia with the Chrome Browser.

I would recommend here to first try wired and wireless connection and also the troubleshooting steps on the very bottom of this article. Maybe this will help to fix your issue.

If it doesn't help, you can also try some Chrome Browser TS steps and see if those are helping. Best would be to try again to link the controllers after each step to see if that solved the issue.

  • Check that you have the most recent Chrome version.
  • Disable all extensions in the browser and check if that solves the issue. If so, activate them one by one again to find out which one is causing the issue.
  • Delete the cache & cookies of Chrome.
  • Check if you have experimental Features (Chrome flags) activated:
  1. Go to chrome://flags.
  2. Search a specific theme to your problem with the search bar and check if you can disable this feature, e.g. "enables pointer lock options" or "hardware accelerated video decode".
  3. If you can't find those, click on "reset to standard" in the top right corner to enable the standard-settings of the browser.
  • Check that your Chrome Browser is not blocked by any Malware (check here step 5).
  • Check your PC if there is any Malware/Virus installed that might cause issues in your browser. Try to just run an antivirus-programm to isolate this.
  • Uninstall Chrome and install it again to have a "clean" version.
1 Kudo
Stadia Player
Stadia Player

Hi,

I have had the same problem recently (details in this post from yesterday). 

Try the following, which works for me:

  1. Sign in to stadia.com on Chrome
  2. Install Stadia as a Chrome app
  3. Exit the Stadia Chrome app and exit Chrome
  4. Run the Stadia Chrome app again
  5. Uninstall the Stadia Chrome app; use the option to remove all stadia.com data
  6. Turn on the controller first, then run Chrome again
  7. Sign in to Google
  8. Connect to stadia.com
  9. Try connecting the controller

Obviously this is not an optimal long-term solution. Deleting all browser data or reinstalling Chrome would be massively inconvenient for me, so I hope there's some other real solution.

0 Kudos