Showing results for 
Search instead for 
Did you mean: 
Community Member

Stadia Controller Update Failed

I attempted to reconnect my Stadia controller, which has not been updated since January, to the Stadia app and after successfully connecting to the WiFi the update procedure fails every time. 

I have tried multiple networks, even tried in DMZ mode in case it was a port issue to no avail. After 3 hours of troubleshooting over chat and phone, I tried changing WiFi name and password, hard reset of controller, even drove to Starbucks to try their network. All resulted in failed updates. 

When I connect through the browser, the controller will link up, however the performance is extremely poor. I can only assume this is due to the outdated firmware on the controller. 

They tried to start an RMA but they required a picture of serials on the box which I no longer have, a picture of the serials on the devices (I defy you to take a pic of the Chromecast Ultra serial on the device) and a picture with the last 5 digits of the reference number. 

I was told it would be an advance replacement, however they could not get the order to go through. I was then told it would be over a two week process to send my devices back and then once received, they would send the replacements out. I was also informed they are not able to refund or pro-rate my Stadia subscription despite being without the defective device for over half a month. 

Has anyone else encountered this issue? If so what was the work around? Any suggestions on troubleshooting options? 

Really couldn't be more disappointed on how this was handled. 

0 Kudos
1 Reply
Community Member

I am having the same issue. My controller tries to update everytime i turn on the Stadia but fails. After about 1.5 minutes it lets me play but the controller update failed. We also have a Google Home that is telling us "fetching update 0%" and fails. It is something with Google products failing to update on the Wi-Fi. I have tried turning off/on IPv6, turning on/off airtime fairness, and tons more, with nothing working for either product. I had the same issue when we first got the Stadia and had to use a hotspot instead of my wifi to get it setup. 

0 Kudos