cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Community Member

Controller keeps unlinking frequently

About every 10 to 15 minutes while in a game a message pops up asking me to link my controller, putting in my link codes does nothing. I have to turn off the controller and turn it back on and then put in the code before it will accept it. If I play with a keyboard & mouse in a chrome browser, I get kicked out frequently due to unstable connection even though I have 400 mb/s connection but I have a stable connection if I use chromecast with a controller. Either way I am unable to play Stadia without frequent interruption. Either I have a dislinking controller or a dislinking connection (but not both at the same time).

4 Kudos
14 Replies
Highlighted
Community Member

I still have this problem everyday. Has anyone found a fix?

2 Kudos
Highlighted
Community Member

I have this same issue where my controller disconnects and it asks me to link the controller but I cant

2 Kudos
Highlighted
Community Member

Same issue, started happening recently playing doom 

0 Kudos
Highlighted
Community Member

Do you have multiple routers in your home?  Make sure you are connecting to a wifi network with only 1 access point.

0 Kudos
Highlighted
Community Member

Also... Try setting up a guest network and see if that resolves it.

 

0 Kudos
Highlighted
Community Member

Have the same issue. Stadia support is sending me another unit. No idea why my laptop struggles with stadia on Chrome. Connection is excellent and super low ping. 12ms. Just gets super choppy no matter which game i try. While on Chromecast with controller i get full 4khdr with no issues. Except for controller randomly deciding to unlink. Can still control menu buttons but nothing in game. Says no controller is linked. Yet i can use it to navigate menus. Super weird. But it is being looked into. It will get better 

0 Kudos
Highlighted
Community Member

Hello everybody,

yesterday (well today early morning) when I playing Grid facing this issue twice in a couple of minutes (maybe less than 10 minutes). Now after a deep research I found interesting information about this case:

  • Stadia Controller use 2.4ghz band to connect to wifi.
  • At around 4 AM (the time when I facing the issue) the controller magically change the local IP (I guess because get disconnected from the wifi).

    Dema_0-1585644649682.png

What I do now? Well I set a static IP for the controller in my Router using the MAC address in case the controller get disconnected or had a microcut this will had the same local IP (example 192.168.254.324). 

At moment I not test it again but I'll maybe today night and see what happen. Maybe the linking issue dont have any relation with the connectivity but at least maybe this could help to solve something.

Cheers,
Dema.

Cheers,
Dema.
0 Kudos
Highlighted
Community Member

I have been having this exact issue for weeks.

1 Kudo
Highlighted
Community Member

I've been having the same issue since the day I received the controller. This is sad. 

0 Kudos