Showing results for 
Search instead for 
Did you mean: 
Community Member

Controller doesn't connect to browser when using 5 GHz network

This applies to using the Stadia controller via the browser. When I've connected the controller to my 2.4 GHz network it pairs perfectly fine, but when I've connected it to my 5 GHz network it doesn't work at all. Is this a known issue?

EDIT: To further specify, I've run into this issue with Google Chrome and variants such as Brave, Edge, and regular Chromium. This also happens on MacOS and Windows. I've run into this issue with my TP-Link C3150 v2 and with the Experia Box v10 at another place.

0 Kudos
3 Replies
Stadia Guide
Stadia Guide

@DryRoastedLemon Have you tried Incognito mode? I'm having the same issue with not being able to connect the Stadia controller to Chrome browser, but it works when I switched to Incognito.

Please @mention when replying to me, so I can get notified
1 Kudo
Community Member


That's really interesting. I tried a bunch of things and was able confirm what you said:

  • Using Google Chrome I can't get the controller to work on 5 GHz in regular mode, but it works perfectly fine when in incognito mode.
    That said, in regular mode it does seem to connect. It just doesn't show in the browser, and after a minute or so the controller disconnects automatically. Closing the Stadia browser tab also immediately turns the controller off, leading me to believe that a connection is established.
  • Using plain Chromium works the same way.
  • Using Brave and Edge don't work with 5 GHz at all, even in incognito mode. Using 2.4 GHz is the only way to use the Stadia controller for these browsers.
0 Kudos
Community Member

I can confirm as well. Doesn't work in regular mode. Only incognito. I went through the massive pain of doing away with all my extensions just to see if that was the culprit, but it wasn't.

This is a MASSIVE inconvenience with a password manager-generated password and 2FA so hopefully they get it resolved soon. 

0 Kudos