cancel
Showing results for 
Search instead for 
Did you mean: 

Wrong language when playing on CCU

Hi My Spanish friend is struggling to get the CCU to play games in Spanish. They have everything set up to work in Spanish on their laptop and phone and it works perfectly. However when they start a game on my CCU (set up in English in the UK) it defaults to English. Are we doing something wrong? He has launched a game from his phone and using the stadia controller, neither works. I'd have thought it would start a game in the language of whatever the account is set up as, but for him it doesn't. Any ideas?
1 Kudo
3 Replies
Stadia Guide
Stadia Guide

Hey @GamingPreferred,

I had a similar thing with my games: I am German, but my boyfriend is UK. Therefore we want to play our games in English, but my whole Google account + Stadia is in German.

I figured out, that it works when you just change the language of your chromecast in the Google Home App, just do the following:

  1. Open your Google Home App.
  2. Select the room where your device (chromecast) is set up.
  3. Click on the settings in the top right corner.
  4. Change the language under "language" to the one you want your games in.
  5. Open Stadia on TV and enjoy!

This worked wonderfully for me. Our first two games in Mortal Kombat 11 were in German and then I switched to English by changing the Chromecast language.

0 Kudos

@Chufu  thanks, the only problem is, I'd want it in English and they want it in Spanish, so we'd have to keep switching.  Hopefully they will improve things for bilingual households. 

0 Kudos
Community Member

@Chufu This has now helped me, as well. Have one Kudo from me! 😀

1 Kudo