cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Audio/Video sync way off

Jump to solution

I have major audio/video sync issues with Stadia... but on the same chromecast ultra my other apps have no audio sync issues. Anyone else experiencing this?

Tags (1)
9 Kudos
1 Solution
Community Member

Hello all.

Just wanted to share my update:

I have a TCL Roku TV and was having really bad audio lag playing on CCU. It was really apparent in Destiny 2. I finally fixed mine by disabling the "Volume mode" in my TV settings. The one that keeps the volume highs and lows a bit leveled. I now have no lag.

So if you have that setting on your TV or whatever sound system you're using, perhaps try turning it off.

This probably won't help most of you, but hopefully it can help at least one other person.

View solution in original post

0 Kudos
111 Replies
Community Member

Same issue here. Also only getting PCM stereo and not 5.1 in stadia. Plex and Netflix will do 5.1.

 

CC Ultra>Sony Bravia HDMI1>HDMI4(arc)>Yamaha receiver.

0 Kudos
Community Member

For 5.0 audio surround, you need to put the CC into the yamaha:

CC -> Yamaha -> TV

I haven't seen 5.1 working.

0 Kudos
Community Member

Same issue, only TV and Chromecast ultra involved. streaming other things like youtube, google play movies NetFlix are all in sync.

given that other apps on the same chromecast don't have the issue I wouldn't think it matters, but the tv is in game mode, i have all audio "features" turned to off.  tv is a 6 + year old 1080p Sharp TV.  I even plugged it into another TV and still got the same issue.

both cases the chromecast ultra was connected by ethernet.     

Chromecast---->Netgear Switch---->google Wifi (1st gen)

I will try it with Wifi just to see later today.

I can stream to my pixel 2 Phone and my Chromebook over wifi and the audio lag is not noticeable (side by side with an Xbox plugged in to one of the above-mentioned TVs and it was about the same. Destiny 2 on both screens, shooting hand cannons to test).

Google support case 2-6835000028477 in case google reads this

 

 

1 Kudo
Community Member

Also having this issue.

I have a Sony 4K TV with a Sony soundbar. The soundbar is connected to the TV via the ARC/eARC specific HDMI socket.

I've tried connecting the chomecast Ultra to both the TV directly, and into the soundbar. Both have really bad audio lag.

If I stream anything to the chromecast (youtube, netflix etc) the audio sync is fine, it's just stadia

 

However, if I plug my headphones into the stadia controller the audio is perfect.

 

I'm definitely going down the track of thinking there is something wrong with the sync between the Chromecast Ultra and Stadia and isn't something us consumers can fix!

1 Kudo
Community Member
... "However, if I plug my headphones into the stadia controller the audio is perfect." EXCELLENT temporary solution! Thank you! 😄
1 Kudo
Community Member

How is the quality / volume when using the headphone jack?

 

Cause I have €350 headphones driven by AVR + headphone amp for virtual surround and proper bass and amping. I can't imagine the stadia controller doing that adequately.

0 Kudos
Community Member

Same issue here with CC wired to router. Sonos connected via optical. Delay is always present and can be significant at times. LGTV 4K with Sonos 5.1. No issues with YouTube or Netflix. Hopefully this can be fixed with a firmware update. I also find when I first start playing the screen turns black intermittently as if the stream is switching from hdr to sdr. Stops after 10 mins - it’s like Stadia needs to warm up. Not having the best experience so far although I must say the stream itself doesn’t lag and neither do the controls. Please help Google as I am only putting up with this in the hope we get a quick fix!

1 Kudo
Community Member

I’ve been playing MK11 today and the sync comes and goes. Really off putting! It started in sync and then almost reset itself then the audio starts to slip again. Rinse and repeat.

The fact the audio can be behind or ahead at various rates while playing is baffling. 

MK11 Experience see an example here of a video I just recorded of gameplay.

Please sort google! 

1 Kudo
Community Member

My observations regarding the sound topic in Destiny2:

Chromecast Ultra on TV:

  • HDR is washed out
  • 5.1 Surround Sound not enabled besides my TV has eARC (HDMI 2.1 already) and Receiver is supporting it, too
  • Sound is delayed for about 0.25 seconds

 

Chromecast Ultra on Receiver:

  • HDR is washed out
  • 5.1 Sound working
  • Sound is delayed but only hardly noticable
1 Kudo
Community Member

Anyone had any luck getting some help from Google on this?  I submitted a form through here on Sunday:

https://support.google.com/stadia/contact/stadia_social_support_inquiry

Haven't heard anything yet. Didn't even get an email acknowledgment. 

I tried connecting the Chromecast directly in the TV instead of the receiver. Same issue: audio is late. Everything else is great.

0 Kudos
Community Member

I'm not expecting a fix anytime soon, that's why I just filled out the return form...

 

Those support people will probably first let your reboot/reset/restore factory your TV, receiver, chromecast, phone, router and phone.

Then they will say that your situation is not supported and you can only use the CC directly in the TV with no receiver.

0 Kudos
Community Member

I have CCU connected to tv with receiver working through the ARC. Tried connecting directly to the receiver which did improve the delay but it was still there. Also tried with the receiver at all and it’s still there. Casting YouTube videos is fine. I have also tried rebooting Stadia and have reset my CCU to factory settings. Nothing works. Kinda crazy that everyone doubted the video latency and yet that works fine and it’s the audio that’s rubbish. Btw it happens across both destiny and samurai shodown.

0 Kudos
Community Member

😁😂😪😣

0 Kudos
Community Member
@Jerdaz Im using a pretty basic pair of YKG headphones so they aren't high end quality.. the audio out of the controller is on the quiet side but sounded to be around the same quality as when I use them on my PC or switch.. subjective though so difficult to say really.
1 Kudo
Community Member
Has anybody made any progress with this? I've tried sending a tweet to stadia and I've not had a reply. The only thing I have found so far is if I turn off game mode on my TV. I get really bad input lag, but the sound is then sync'd up with the visuals. I'm not sure what that's telling me but I hope somebody from google is reading this and may be able to shed some light on this issue? It's at a point where it's making Stadia unplayable on my chromecast at the moment.. @GraceFromGoogle can you help here?
2 Kudos
Community Member

Same issue. Tried Destiny 2 for the first time and immediately noticed the audio out of sync. As with everyone here: game performs great, no input lag. But audio is late. Very noticeable, even during dialog scenes. Chromecast ultra with ethernet, hooked to Denon AVRX-4500. TV in game mode. I have consoles and other streaming devices: no audio sync issues. It’s Stadia. Very annoying. Hoping they fix this quickly.

2 Kudos
Community Member

Youtube will sync the audio with the video, if you did this on a video game you'd see latency on input. I'm having the same issues with chromecast only, my laptop is fine, just the chromecast seems to have the audio latency.

0 Kudos
Community Member
I'm having the same issue. CCU is connected to the TV directly, no sound bar, no receiver. Hope this gets fixed soon because it's really annoying.
1 Kudo
Community Member
I'm also experiencing audio lag when playing through the Chromecast Ultra. It's connected directly to the tv. Tried turning off all sound enhancing features when using the TVs game mode. (My first try was to use the default settings in game mode.) The audio lag is big enough to be noticed when shooting guns and when there are character dialogs. Can feel it in all games (Red Dead 2, Destiny 2 and Samurai Showdown). There is no audio lag when I play in Chrome on my 7 years old MacBook Pro.
1 Kudo
Community Member

Same issue here on CCU, directly connected to TV sound goes via ARC to sound bar. CCU is connected via Ethernet.

0 Kudos
Community Member

Can everyone test again. Thx google/bungie i think they fixed it!!! Without changing anything its perfect synced now. Yeees!! Now stadia is perfect :-)))

 

EDIT: But now it's only stereo. No 5.1 anymore. Maybe they just trying out stuff on the other end of the line....

0 Kudos
Community Member
Couldn't edit my last post. After pulling out the energy adapter from stadia und rebooting my TV the 5.1 works again and is still synced. Call me the happiest person tonight 🙂 i hope that the audio works now for everyone how it should. Google did something^^
0 Kudos
Community Member
This is 100% not fixed. I'm still getting a pretty massive audio delay and it's quite infuriating. Chromecast is plugged directly into the TV. No sound system just the TV speakers. Game mode enabled. Ethernet plugged directly in the Chromecast with consistent "Excellent" connection speed. Video is perfect with no perceptible input lag, but man the audio behaving this delay is actually making me go insane. 😞
0 Kudos
Community Member

No change for me either. Still out of sync.

0 Kudos
Community Member

Ok thats weird. But why is it suddenly working for me. It never worked since launch. And all of a sudden it does work. I didn't change anything. I had the chromecast plugged in my gamining monitor für 5 mins to test the input lag (controls). Plugged it back into the tv and a few hours later i played destiny and the sound was working correct. Maybe a server thing. I do live in germany. A friend who tested utvlives although in germany and it worked. Our cities are round about 300km apart.

0 Kudos
Community Member

I wish I had the answer. It's good that it's working for you now. But quite frustrating that Google has not even acknowledged the issue. What is clear is that this issue obviously doesn't affect every Stadia user otherwise it would be so widespread and rampant that every news site and review would be mentioning it. 

Hard to say whether this is a hardware issue, firmware issue or a software issue. But it's not something that affects us all and unfortunately that may be the reason google has yet to confirm the issue.

The only thing I know is its definitely not an issue with my TV or the chromecast on it's own. You Tube and Google Play Movies have perfect audio and video sync for me. It's only Stadia on the Chromecast that I have the audio issues.

 

0 Kudos
Community Member
Unfortunately it is still there for me. I don’t have the confidence to buy any more games at present. Until it’s fixed I won’t continue my Pro subscription after the trial. Fingers crossed it is fixed as the service is great otherwise. Come on google!
0 Kudos
Community Member

I know it sound stupid but do you have the possibility to connect your ccu to an hdmi monitor? Maybe it's worth a try. And after that reconnect to TV. I hooe it will eork soon for you guys to. But who knows. Maybe it was a coaccident yesterday and today it's again not synced. I will test it later again.

0 Kudos
Community Member

Thats so weird. After 5 days desynced sound it worked the whole day yesterday withou changing anything. Today it's desynced again....

 

Edit: pulled out the stadia power plug and restarted tv and stadia...its working again synced......

0 Kudos
Community Member
I can try resetting my Chromecast. But even if it works, sounds like it's a temporary fix. It's not even a proper fix. Google definitely needs to patch this through a firmware update. None of us should have to constantly fiddle with unplugging and replugging anything
0 Kudos