cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Stadia stuck on "Checking your connection..."

I've been trying to enjoy the free Stadia pro but I can't seem to launch any game.

Any game I try to boot up it just says "Checking your connection..." and after a few minutes it prompts me to re-open the game to play with the only option being OK which closes the game, I assume it timed out.

The ports of 44700 to 44899 are open, pop-ups are enabled, JavaScript is enabled. I've tried running without any chrome extensions or in incognito mode. I've tried with and without VPN. I've tried rebooting my system, turning of my firewall. Nothing seems to work.

This issue exists for all titles on my account. The issue also persists in the downloaded Stadia launcher. I do not own a chrome cast or chromebook to try it on. This is just on windows 10, I have the latest chrome version and my internet up and down is between 200 and 300 mbs.


I am honestly out of ideas at this point so if anyone has an idea I would much appreciate it.

1 Kudo
16 Replies
Community Member

It can be 2 things 

1. don’t use a vpn

2. your WiFi is to slow

0 Kudos
Community Member

Thank you for your reply but as I said in my post. I  tried it with and without VPN and my ethernet is far above their recommended for Stadia.

0 Kudos
Community Member

Hi  maybe you are too far away from the router and try an internet cable if you haven't not tried it and see if it help. And mabey wil it help tho change the settings in the mobile stadia app and set the setting's lower the settings >  data usage and presentation. 1080p or 720p mabey it wil help. i have no problems whit stadia game streaming.

0 Kudos
Community Member

if it does not work, restart your modem for 30 seconds, maybe your internet is ping the high so it does not work well for you

0 Kudos
Community Member

8dd0658-1 (1).png

0 Kudos
Community Member

I have the same problem, any solution? i have even tried installing windows again and nothing

0 Kudos
Community Member

This issue has been a plague since launch.  Search for  "checking your connection"  in the forum search, you'll see threads WITH ZERO SOLUTIONS and a lot of frustrated gamers.   No google rep has helped or really provided any meaningful "we going to fix this!" gumption... we're just kinda screwed !   yayyyyyy! 

0 Kudos
Community Member

Use chrome in incognito mode. You have a plug-in preventing you from playing.

0 Kudos
Community Member

The original post says they've tried incognito mode. I'm having the same issue, even when I'm in incognito mode.

0 Kudos
Community Member

Die you try the Dev-Version of Chrome? It is 2 Versions Ahead and maybe it fix this issue 😁

I use the Dev Version for stadia and my performance is better since then

0 Kudos
Community Member

I had the same problem and I found the cause was the TunnelBear VPN extension on Chrome (even if tuned off). I had to completely disable it from the extension menu.

0 Kudos
Community Member

I had this happen on a small laptop with less resources that I wanted to try to see if Stadia would work.  My router would connect at 5Ghz and 2.4Ghz depending on the device.  The device was not that old.  It is a touch screen Windows 10 device, but is too slow to do much more than web browsing.  It only connected at 2.4Ghz, so I assumed that was the problem.  I assumed Stadia required a faster connection.  A number of android devices don't connect at 5Ghz though.  I have family come up from Peru and all of their devices use the 2.4Ghz setting.  None can connect at 5Ghz.  I don't know how you can guarantee the speed at which a Chromebook would connect.  They come at all different price points from $150 to $400 or even more.  More may be involved here than mere Internet speed.  Device requirements may also be important.

0 Kudos
Community Member

Goooooogleeeee,  we neeeed a fixxxxxxx.... still. 

0 Kudos
Community Member

BUMP - a month later. No fix. No acknowledgment.  This will likely be fixed when Google decides to shelve Stadia in a year (like they do everything else). 

0 Kudos
Community Specialist
Community Specialist

Hi @ChromeDome -- if you are still experiencing this issue, please do two things:

  1. Contact our Support Team and specifically outline the issue you are having
  2. Leave feedback in the Stadia app on your mobile device. To do this, tap on your profile icon, then scroll down to the "Feedback" button. Be as specific as possible about your circumstances and symptoms.

Thank you, and we'll do our best to get to the bottom of this issue.

0 Kudos
Community Member

I think I figured out my "Checking your connection..." problem with Stadia and I wanted to share. I believe it had something to do with Linux.

My solution was basically not start Linux anything after a fresh restart and without any connected peripherals and then start Stadia (not in Incognito), then plug in my USB controller and viola... That process got rid of the "Checking your connection" circle of infinity to finally disappear.

Note that I'm still running the following extensions: Stadia+, uBlock Origin and PiP by Google.

tl:dr - I think it was Linux

0 Kudos