cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Stadia no longer wants to work properly "Unstable Connection"

I have 56.009 mbps used the stadia speedtest and yet both destiny 2 and PUBG continues to say unstable connection with visual skips as well as blurring and pixelation. It crashes within 20 seconds of opening the directory in D2. Why is this happening IDK. Seems rather fishy if you ask me. I already chatted with someone from the Stadia and did what they asked but nothing fixed my problem nor do I think it will ever be fixed. My ISP has no data caps so I truly can't think of anything that could be the problem other than Stadia. Stadia is my suspect atm. I supported stadia, talked about them and to have this happen to me a consumer who looks forward to improving Stadia is bizarre. I have submitted feedback like 5 times, really providing details to help them grow and what not. As long as this problem persists I have no intention of speaking about stadia or anything to do with stadia for that matter. Goodbye.   

0 Kudos
1 Reply
Stadia Guide
Stadia Guide

Hey @Drogozz12,

sorry to hear you have issues playing in the Chrome Browser on Stadia because of the error "unstable connection".

I would recommend to try the following in this case:

First: Try to isolate the issue. Does it work when you play those games on TV or on a mobile device? Or does the problem exist everywhere? If it exists everywhere, it might be a game-issue itself. If it only happens in the Chrome Browser there might be something wrong with the browser.

Second: Try the steps mentioned in this article to fix connection and network problems.

Third: If you isolate that the issue only happens in the Chrome Browser, check these steps to fix the browser:

  • Check that you have the most recent Chrome version.
  • Disable all extensions in the browser and check if that solves the issue.
  • Delete the cache & cookies of Chrome.
  • Check that your Chrome Browser is not blocked by any Malware (check here step 5).
  • Check your PC if there is any Malware/Virus installed that might cause issues in your browser. Try to just run an antivirus-programm to isolate this.
  • Check if you have experimental Features (Chrome flags) activated:
  1. Go to chrome://flags.
  2. Search a specific theme to your problem with the search bar and check if you can disable this feature, e.g. "enables pointer lock options" or "hardware accelerated video decode".
  3. If you can't find those, click on "reset to standard" in the top right corner to enable the standard-settings of the browser.
0 Kudos