cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Performance on Chrome Browser

Jump to solution
Hi all and a happy 2020, I encounter the same problem as many others here with stability of Stadia gameplay. Using WLAN (meshed) I often get lags and blurry display up to disconnetions - on ChromeCast Ultra and in Chrome Browser. After using a cable it improved much on CCU but not on my Notebook with Chrome Browser. I also tried to disable hardware acceleration. The blur vanishes, aswell as "bad connection" messages from Stadia. But now I got huge input lags. Playing GRID looks a bit better now but the car can't be controlled. It often takes almost a second before a steering command is executed. My internet connection is around 50Mbits and while playing on Stadia uses around 15 to 20 Mbits bandwith. I read the several help docs and tested my connection with good results (~45 MBits even with WLAN). I have this problem on almost all games (the ones included in Stadia Pro and GRID). Is there any trick to make games playable on my notebook? Best regards, Yegoya
1 Kudo
1 Solution
Community Member
2 Kudos
5 Replies
Community Member
2 Kudos
Community Member

Hi @davidking 

Thanks! That really helped a lot. The lag is not completely gone but Destiny 2 is almost flawlessly playable.

Let's see how things will improve by Google.

 

Best Yegoya

1 Kudo

How old is your notebook? When I first played Stadia on my 6 year old laptop via wifi, it was laggy as heck for me. Recently I bought a USB wifi adapter and the performance have improved drastically, comparable to playing on the CCU wired.

0 Kudos
Community Member
Yea, to play this platform you need an elite connection (wired) is preferred. Wireless you need to turn mesh off on your wifi settings b/c it causes issues.
0 Kudos
Community Member

Make sure to turn on hardware acceleration in chrome. If using nvidia gpu go to nvidia control panel manage 3d settings and find chrome.exe under program settings tab and set low latency mode to Ultra. Then go to power management mode and select Max Performance. Hit the apply button and Bam the thing should run like you have a chromecast ultra plugged into monitor if not better. 🤓

1 Kudo