Showing results for 
Search instead for 
Did you mean: 
Community Member

Mouse is not smooth, summary of stuttering and input lag (My experience)


Disabling VSYNC improves a lot, try first this:

And disable mouse acceleration:,36886.html



I want to share my concern about the mouse performance on Stadia. I'm trying this things to improve the mouse input lag and stuttering.

  • Go to chrome://flags and reset defaults values (this option is the worst because there are input lag and stuttering clearly)
  • Disable mouse acceleration in your OS (This options helps a little too but I think that with the following option is also the same in this context)
  • Go to chrome://flags and switch off Hardware acceleration to video encode/decode (this option fix the mouse input lag a little but the frame rate sometimes is worse)
  • Go to chrome://flags Mouse Pointer Lock (this option fix the mouse input lag a little)
  • Go to my GPU options (NVIDIA Control Panel) and disable some options as vsync, anisotropic filter, antialiasing and options to priorize the performance over energy save. (This is the better option for me, no input lag and very low mouse stuttering (but still there), is sad that this option cannot be reproduced in MacOS and Linux)

I don't want to make silly comparisons and controversy about game streaming services, but, I'm trying in my Geforce Now account with the same game (Destiny 2) and same net conditions and the mouse works smooth and this problems are inexistents. I think that is because the NVIDIA has a desktop client that can deal with GPU options and behaviors to make a better experience, I don't know exactly but I think that the client (Chrome) is the main problem because is not optimized yet.

I think that google has to provide a better client for stadia in desktop environments and don't to be the users whose has to deal with hw acceleration flags, mouse pointer lock and external tool setups and whatever...

This is my concern because I want Stadia also to play games in desktop with keyboard and mouse, not only with Stadia Gamepad.



2 Kudos
9 Replies
Community Member

@TekoRaiK : What mouse driver do you, or do you have a Logitech mouse? If you have a Logitech driver what is the polling rate configured as?   If you have some other branded mouse, does that report a polling rate, and if so what is the polling rate.

As for differences between Stadia and GFN, as you understand already they are completely different services using completely different technologies, so it would be quite normal to see that different behaviors occur with different setups.  Not everyone has had to mess about with their Chrome settings to get things to work, but on some PC's folks have had to.   Once again this is just typical of the PC environment not something specific to just running a Chrome browser etc.

Kudos appreciated if deserved.
0 Kudos
Community Member

Thank for the reply and the attempt to help.

I have in ubuntu a Logitech Mouse with 250Hz of mouse polling rate. Also a MacBook Pro with hewlett packard mouse and I don't know how to see mouse polling rate information. With 2 configurations I have the same results.

I understand that GFN and Stadia have some differences, I just wanted to clarify that the network is not the main problem and also that the client (Chrome in this case) should to deal with this kink of issues.

0 Kudos
Community Member

I want to clarify that in my case the gaming experience is quite good in Stadia with keyboard and mouse, the gameplay is not ruined by this. But it is a bit annoying but it is not ideal especially considering that with the gamepad it works perfectly (it is not a stream problem)

0 Kudos
Community Member

@TekoRaiK : Do you continue to get the issue if you reduce the polling/report rate of the Logitech driver further? e.g. 200 or 125?

Kudos appreciated if deserved.
0 Kudos
Community Member

@TekoRaiK a very interesting post. I think you are right about the the problem that some people are seeing with desktop gaming is the way that the Stadia client is running under Chrome. 

I can run Stadia on a high end laptop with no problems (after disabling mouse acceleration).

On my Dell 11 3120 Chromebook (through a USB Ethernet port) I get this (tested in Destiny 2):

  • Sanding still, good graphics and very low lag when firing a gun (<100ms)
  • Moving with keyboard, very fluid and good graphics and slightly increased lag when firing (but still pretty low, maybe 150ms)
  • Moving with the mouse, stuttering graphics, high lag (maybe 400+ ms)

I think the stadia client or chrome is not handling sending packets very well, especially when there are lots of updates to send (such as moving the mouse). That ties in with the improvement people getting when lowering the mouse polling rate. I think the client or chrome has a to get a balance between the priority it puts on sending and receiving. This is a big problem they must solve before rolling out the base product, as it needs to work out of the box else people will dismiss it.

1 Kudo
Community Member

same for me except that the mouse controlling feels so much smoothen out that its realy hard to aim in games like destiny. 

0 Kudos
Community Member

Ive tried both on my pc that i normally play destiny on, and on my chromebook  both, and sitll have horrible input lag no matter what i try when using the mouse, To the point that I gave up and just kept using the controller. 

Ive tried using both a plug and play mouse that ive got for gaming, as well as my razer atheris that i have for the chromebook. Its brutal to try and use.

0 Kudos
Community Member

I've tried the steps TekoRaik provided. There is still serious mouse input stuttering even though the frames of the game appear smooth. The game just stops receiving input from the mouse and keyboard for a few moments and then jumps to the new position. 

I've also reduced my mouse polling rate to 125 to help with matters. This issue also persists when I reduce the visual quality to 720p.

Any other ideas?

0 Kudos
Community Member

Another tip, disabling vsync when you open chrome:

And disabling mouse acceleration:

And using chrome canary (with step of vsync above):


Now I recommend not to disable acceleration:

Go to chrome://flags and switch on Hardware acceleration


If you are using Mac you can open chrome canary with vsync disabled with this command in a terminal:

open -a "Google Chrome Canary" --args --disable-gpu-vsync --disable-frame-rate-limit

If you are using Mac but you don't have chrome canary is almost the same command:

open -a "Google Chrome" --args --disable-gpu-vsync --disable-frame-rate-limit

To disable mouse acceleration in Mac system execute this command in the terminal:

defaults write .GlobalPreferences -1

And also in Mac this can help a lot when you are connected via wifi:

0 Kudos