cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Mouse is jumping / teleporting - this paid product is unusable to me right now

Hi everyone,
as a few here I also have the issue in stadia (not in a particular game) that my mouse movement won't get translated correctly.

When I move the mouse in the destiny menu the cursor teleports and skips large areas of the screen completely. The consequence is that destiny is unplayable with the mouse.

I am very frustrated by this since I am under the impression I paid for a Beta product. If it would have been marketed / communicated by google as such it would be ok, but as you all know it wasnt. Close to the release many features weren't ready which almost made me my founders order cancel. Now I waited and wanted to look for myself. 

I tried to use the chrome dev version, which oddly at first got rid of the mouse input bug, now its back. Now I read that it could help to reduce the polling rate of the mouse.
This is not the experience I hoped for and I wont install extra software to configure my mouse everytime I wanna play on the stadia platform.

I feel ripped of at this point to be honest. I posted videos about this bug, searched in my own time for fixes and found nothing working so far. A compensation is the least I expect at this point and I hope that anyone from the google staff will read these lines and get back to me since I got no response regarding this issue with video proof via tweet, feedbackform or discord message.

I really tried to reach out and get help. This post is my last attempt to get help solving this since my time, as yours, is more valuable to me at this point than trying to help one of the biggest companies on our planet to get their well marketed product right.

 

EDIT

FOUND MY FIX

i installed the software for my mouse and decreased the polling rate from 1000 to 125.
Now the mousejumping is gone.

4 Kudos
18 Replies
Community Member

@Solano 

Seen a few instances of this now.

Most likely incorrect flags have been set in Chrome.  Navigate to the URL chrome://flags/ then check that both the following are set to Enabled

  • Hardware-accelerated video decode
  • Hardware-accelerated video encode

If that doesn't address the issue, just click the Reset all to default button, restart Chrome and you should be in good order.

This appears to resolve the issue of very jerky stuttering mouse movement.

Kudos appreciated if deserved.
1 Kudo
Community Member

Hi, im having the same problem. I have already restored the chrome flags to defaults but the problem with de mouse and keyboard still there. Destiny 2 is unplayable. Any other solution?? Thanks!!
0 Kudos
Community Member

@Mad_dog this, unfortunately didnt do the trick, but thanks for your hint and idea.
0 Kudos
Community Member

@Solano OS, Processor type, Mouse type and driver version?

Kudos appreciated if deserved.
0 Kudos
Community Member

Windows 10 intel i7 4790k mouse is a steelseries rival 310 what driver do you mean? gefroce 441.20 for my rtx 2080 my monitor is oldschool with 1920 x 1080 @60hz
0 Kudos
Community Member

Think I can help you out. Try setting this to enabled in Chrome://flags Enables pointer lock options This is disable any acceleration in the Chrome window. THis has had a positive effect on my experience with mouse and keyboard.
2 Kudos
Community Member

It's Seems to be lot better with pointer lock

0 Kudos
Community Member

@KayZey78 

unfortunately not for me...

0 Kudos
Community Member

@Mad_Dog_Bravo@KayZey78You guys just helped me a bunch. Both your replies pointed me in the right direction. I'm on Ubuntu 19.10 on an intel NUC and it's been laggy for with Mouse and Keyboard, but not with wired stadia controller.

I'm on chrome 78 and I changed these flags:

Accelerated 2D canvas: Disabled

Enables pointer lock options: Enabled

No noticeable input lag now. Thanks a bunch!

1 Kudo
Community Member

@Boost : Awesome news! Have fun!!

Kudos appreciated if deserved.
2 Kudos
Community Member

Same problem with Metro Exodus, play with a mouse is hard with a very notifiable input lag and this is just unplayable in action.

0 Kudos
Community Member

here is the fix which worked for me.

i installed the software for my mouse and decreased the polling rate from 1000 to 125.
Now the mousejumping is gone.

1 Kudo
Community Member

yes , it seem to be to only good working 100% solution. I installed the logitech software for my mouse and at 125 , and its working #1
0 Kudos
Community Member

Changing "Data usage & performance" in the stadia app to "Limited data usage" was the only way for me to get rid of the input lag when playing on ubuntu with chrome and/or chromium.

 

(Best visual quality works fine on the chromecast ultra though)

0 Kudos
Community Member

After hours and hours I found a solution.

Situation: On CCU and on my gaming PC stadia is running perfect, but on my notebook I had this stuttering und jumping.

What I did to get it running:
My Mouse "Classic Intellimouse" and other mice do not have the ability to reduse the Polling Rate (like the most mice). I found out, that the Polling Rate was 1000Hz. This rate is to much for my notebook.

1. Step: 
https://www.overclock.net/forum/375-mice/1589644-usb-mouse-hard-overclocking-2000-hz.html#/topics/15...
Read the first Post. Then start at 4. Software, download the software and do the steps 1-5 and reduce the Polling Rate to 62 - 125Hz.
Restart.
Check the Polling Rate at https://zowie.benq.eu/en-eu/support/mouse-rate-checker.html

If this works happy you.

If not do this:

Warning, doing on your own risk

1. Disable Secure Boot (if its on)
https://www.thewindowsclub.com/disable-secure-boot-in-windows

2. Enable Test Mode
https://www.linkedin.com/pulse/enable-test-mode-windows-10-ajibola-okubanjo

3. Disable Signed Driver Enforcement
https://ph.answers.acer.com/app/answers/detail/a_id/38288/~/windows-10%3A-disable-signed-driver-enfo...

Then try to reduce the Polling Rate again from the beginning. Now it should work.

0 Kudos
Community Member

After trying time and time again to fix this issue with the mouse jumping, I still cannot find a solution. Trying all the flags, polling rates, locking, everything. But the problem persists. 

The people having this problem, do you have multiple monitors? Or just one? I'm currently running 3 (one being 4k) and I have to wonder if it's not a combination of chrome being in fullscreen, cursor locked to the middle, but having a fit when my mouse "reaches the edge" of my monitor before snapping back to the center. 

Unfortunately, I'm too lazy to unplug all my stuff and do in depth troubleshooting, but if this is still happening to people with one monitor then that would answer my question ✌️

 

Otherwise, does anyone have an updated solution for end of Feb.?

0 Kudos
Community Member

same. unplayable on mouse and keyboard

0 Kudos
Community Member

@kSPRo @Relexs and anyone else still having issues after implementing all of the previously mentioned fixes, here's a few other things to try:

  1. Exit Zoom and/or Skype
    1. These get minimized to the tray so make sure you close the process, not just the window
    2. Other programs may have an effect also, so close everything you don't need if the above doesn't resolve the issue
  2. Within D2, press Esc --> Open Settings --> Video --> Screen Bounds then follow the instructions

For me, just by closing Zoom the mouse went from skipping every 5-10 mouse movements down to one skip every 50-100 mouse movements (and it seems to be more common in menus than gameplay).

If anyone knows how to adjust the polling rate via the registry, please let me know! I am on a corporate computer and unable to install any software.

0 Kudos