cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
ghego
Community Member

Google chrome & Linux

Jump to solution

Seems Stadia + Google Chrome on Linux leads in input lag turning the experience unplayable.

Tested on vanilla install of chrome (stable 78.03904.108, beta 79.0.3945.45, dev 80.0.3970.5) and all those are affected.

All of those present hardware accelerated as unavailable feature, and this should be the cause of the problem.

Any idea to get rid of the issue?

Tags (2)
4 Kudos
Highlighted
Alfa-Omega
Community Member

YES !!! IT WORKS !!!

 

I was having some issues running stadia in "Best visual quality" a lot of lag and frame drops, (running stadia with "limited data usage" work flawless btw)

 

Just using chromium with those flags ( --ignore-gpu-blacklist --disable-gpu-vsync) did the trick for me, thanks a lot man.

2 Kudos
Highlighted
algiam333
Community Member
Work very, vey well for mi. I'm happy.
1 Kudo
Highlighted
Orgin
Community Member
If all else fails to reduce the extreme input lag (like it did for me) then do this: In the stadia app tap your avatar on the top right. Tap "Data usage & performance" Select "Limited data usage" (Yes this updates what happens on your pc as well) Looks a bit crappy with 720p on a 1440p monitor but at least the input lag is gone. I have no problem using "Best visual quality" when using the chromecast ultra, but on Ubuntu it's just not happening (same on several different setups) . At least I can play the games with the above settings.
1 Kudo
Highlighted
Halbheld
Community Member
Reducing the quality indeed makes it better and almost playable. But that's the thing: now the stream is light enough to be decoded fast enough under Linux, while the same stream under Windows is significantly faster decoded. Google has to tweak Linux Chrome. That was an important argument for Stadia, at least for me: ditch Windows gaming once and for all.
0 Kudos
Highlighted
algiam333
Community Member
I use Ubuntu with an old and basic Nvidia Gforce. At first it does not work all right, I lost frames and the game had lag. I solved it by changing the drivers that were installed (x.org) by the owners of Nvidia, now it works perfect! With lag "0" it is instantaneous and very soft. I still do not have the command and tried it with a mouse and keyboard. I play high image quality.
0 Kudos
Highlighted
Halbheld
Community Member

Does anybody know the codec Google is using? VP9? The nVidia driver of my GTX 770 tells me in VDPAU info, that it is only capable of MPEG1, MPEG2, H264, VC1, MPEG4, DIVX4 and DIVX5.

0 Kudos
Highlighted
Siedhuss
Community Member
Hello, I found a performance boost for my stadia experience on Manjaro Linux in chrome stable release by changing the cpu governor. To do so: Terminal: sudo cpupower frequency-set -g performance further information: https://wiki.archlinux.org/index.php/CPU_frequency_scaling The result was a lot better then with the stock setting on "schedutil". Btw I have an amd cpu so might be a bit different on intel cpus.
1 Kudo
Highlighted
Valynor
Community Member
@Halbheld Stadia uses VP9 (and likely AV1 in the near future)
0 Kudos
Highlighted
Halbheld
Community Member
One possible solution is, to install a Chromium version with vaapi enabled (available as a snap). See https://www.omgubuntu.co.uk/2019/11/stadia-on-ubuntu-linux-mint The problem is, that you also need an extension (h264ify) to force Youtube to send out h264 videos instead of VP9. I don't think that this works with stadia. Has anyone any progress on this? Our solutions to minimize the stream or maximize the CPU power are okay, but the local graphics card should do its share.
0 Kudos
Highlighted
Valynor
Community Member

Chrome on Linux does not support GPU acceleration yet unfortunately. I'd advise against using that Chromium with VAAPI enabled, it's a very old version with tons of security issues.

0 Kudos