cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
ghego
Community Member

Google chrome & Linux

Jump to solution

Seems Stadia + Google Chrome on Linux leads in input lag turning the experience unplayable.

Tested on vanilla install of chrome (stable 78.03904.108, beta 79.0.3945.45, dev 80.0.3970.5) and all those are affected.

All of those present hardware accelerated as unavailable feature, and this should be the cause of the problem.

Any idea to get rid of the issue?

Tags (2)
4 Kudos
1 Solution

Accepted Solutions
Highlighted
Mad_Dog_Bravo Stadia Guide
Stadia Guide

@ghego :

Some items that I've picked up this week include:

1. Reset Chrome flags - go to the URL chrome://flags , select "Reset all to default", restart Chrome and try again.

2. Run Chrome and use an Incognito window and see if that helps, disable any extensions that might have been added.

3. Reduce refresh rate on mouse pointer (usually a feature on some mouse drivers).

4. Access Chrome flags and enable the feature "Enables pointer lock options".

Can't hurt to see if any of these help with your issue, although apologies if you have tried all of these already.

Kudos appreciated if deserved.

View solution in original post

1 Kudo
24 Replies
Highlighted
Valynor
Community Member

Running Chrome 78 on Linux Mint here (ethernet, kb+m wired), no lag, no problems.

Any lag is likely caused by your network (or the Internet), assuming that your CPU is fast enough to decode the stream in software. If you can watch 1080p videos fullscreen on YT it should be. 

1 Kudo
Highlighted
ghego
Community Member

Forgot to mention:

- connection: Eth 1GB to router

- bandwidth: 127.88 Mbps checked with Stadia speed test

- cpu: i5-8350U

- ram: 32 GB

0 Kudos
Highlighted
ThOR27
Community Member

Well, what I can say is that I have a much lower specs than yours, running Ubuntu 18.04, and it runs just fine, also decoding everything via software.

Maybe the problem is something else, probably related to the network? I know the network speed is fine when tested, but maybe your router is not powerful enough to maintain the same latency with Stadia load?

When I bough few years ago the Steam Link I couldn't play with my router because it kept topping it's memory usage and then it started dropping packages, so I replace with a more powerful ASUS router and it everything worked perfectly 🙂

So might be some kind of hardware in the middle of your network (router/modem) that might be adding a bit more delay to it than it should.

just a guess, of course!

0 Kudos
Highlighted
AdmiralJT
Community Member

I played RDR2 for about 4 hours last night in chrome on my Linux PC using a DS4 controller because my Stadia controller arrives tomorrow. I had zero issues. The game ran better like this than it did on PS4.

 

Ryzen 7 2700x

GTX 1060 3 GB

16 GB ram

Ubuntu 19.10 with KDE and Vanilla chrome

300 Mbps down and 40 up, wired to the router

 

 

 

 

0 Kudos
Highlighted
lox
Community Member

After some trial and error i got rid of the input lag.

step 1. Install patched chromium-vaapi

step 2. install vaapi driver

step 2. chromium --ignore-gpu-blacklist --disable-gpu-vsync

the vsync option is what makes the difference.

unfortunately google-chrome is not fixed with these flags

2 Kudos
Highlighted
Halbheld
Community Member
Just adding my experience, that Chrome on Windows runs perfectly, while Chrome on Linux Mint 19.2 has so much input lag, that it is unplayable. Same machine, same connection. We need that hardware accelerated video decoding, I guess.
0 Kudos
Highlighted
Mad_Dog_Bravo Stadia Guide
Stadia Guide

@ghego :

Some items that I've picked up this week include:

1. Reset Chrome flags - go to the URL chrome://flags , select "Reset all to default", restart Chrome and try again.

2. Run Chrome and use an Incognito window and see if that helps, disable any extensions that might have been added.

3. Reduce refresh rate on mouse pointer (usually a feature on some mouse drivers).

4. Access Chrome flags and enable the feature "Enables pointer lock options".

Can't hurt to see if any of these help with your issue, although apologies if you have tried all of these already.

Kudos appreciated if deserved.

View solution in original post

1 Kudo
Highlighted
ghego
Community Member

Forgot to reply here for me enabling "Enables pointer lock options" worked fine on popOS!, didn't check yet on Arch

1 Kudo
Highlighted
Halbheld
Community Member

"Enables pointer lock options" doesn't change anything for me.

0 Kudos