cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Google chrome & Linux

Jump to solution

Seems Stadia + Google Chrome on Linux leads in input lag turning the experience unplayable.

Tested on vanilla install of chrome (stable 78.03904.108, beta 79.0.3945.45, dev 80.0.3970.5) and all those are affected.

All of those present hardware accelerated as unavailable feature, and this should be the cause of the problem.

Any idea to get rid of the issue?

Tags (2)
4 Kudos
1 Solution
Community Member

@ghego :

Some items that I've picked up this week include:

1. Reset Chrome flags - go to the URL chrome://flags , select "Reset all to default", restart Chrome and try again.

2. Run Chrome and use an Incognito window and see if that helps, disable any extensions that might have been added.

3. Reduce refresh rate on mouse pointer (usually a feature on some mouse drivers).

4. Access Chrome flags and enable the feature "Enables pointer lock options".

Can't hurt to see if any of these help with your issue, although apologies if you have tried all of these already.

Kudos appreciated if deserved.

View solution in original post

1 Kudo
24 Replies
Community Member

Running Chrome 78 on Linux Mint here (ethernet, kb+m wired), no lag, no problems.

Any lag is likely caused by your network (or the Internet), assuming that your CPU is fast enough to decode the stream in software. If you can watch 1080p videos fullscreen on YT it should be. 

1 Kudo
Community Member

Forgot to mention:

- connection: Eth 1GB to router

- bandwidth: 127.88 Mbps checked with Stadia speed test

- cpu: i5-8350U

- ram: 32 GB

0 Kudos
Community Member

Well, what I can say is that I have a much lower specs than yours, running Ubuntu 18.04, and it runs just fine, also decoding everything via software.

Maybe the problem is something else, probably related to the network? I know the network speed is fine when tested, but maybe your router is not powerful enough to maintain the same latency with Stadia load?

When I bough few years ago the Steam Link I couldn't play with my router because it kept topping it's memory usage and then it started dropping packages, so I replace with a more powerful ASUS router and it everything worked perfectly 🙂

So might be some kind of hardware in the middle of your network (router/modem) that might be adding a bit more delay to it than it should.

just a guess, of course!

0 Kudos
Community Member

I played RDR2 for about 4 hours last night in chrome on my Linux PC using a DS4 controller because my Stadia controller arrives tomorrow. I had zero issues. The game ran better like this than it did on PS4.

 

Ryzen 7 2700x

GTX 1060 3 GB

16 GB ram

Ubuntu 19.10 with KDE and Vanilla chrome

300 Mbps down and 40 up, wired to the router

 

 

 

 

0 Kudos
Community Member

After some trial and error i got rid of the input lag.

step 1. Install patched chromium-vaapi

step 2. install vaapi driver

step 2. chromium --ignore-gpu-blacklist --disable-gpu-vsync

the vsync option is what makes the difference.

unfortunately google-chrome is not fixed with these flags

2 Kudos
Community Member

YES !!! IT WORKS !!!

 

I was having some issues running stadia in "Best visual quality" a lot of lag and frame drops, (running stadia with "limited data usage" work flawless btw)

 

Just using chromium with those flags ( --ignore-gpu-blacklist --disable-gpu-vsync) did the trick for me, thanks a lot man.

2 Kudos
Community Member
Work very, vey well for mi. I'm happy.
1 Kudo
Community Member
Just adding my experience, that Chrome on Windows runs perfectly, while Chrome on Linux Mint 19.2 has so much input lag, that it is unplayable. Same machine, same connection. We need that hardware accelerated video decoding, I guess.
1 Kudo
Community Member

@ghego :

Some items that I've picked up this week include:

1. Reset Chrome flags - go to the URL chrome://flags , select "Reset all to default", restart Chrome and try again.

2. Run Chrome and use an Incognito window and see if that helps, disable any extensions that might have been added.

3. Reduce refresh rate on mouse pointer (usually a feature on some mouse drivers).

4. Access Chrome flags and enable the feature "Enables pointer lock options".

Can't hurt to see if any of these help with your issue, although apologies if you have tried all of these already.

Kudos appreciated if deserved.

View solution in original post

1 Kudo
Community Member

Forgot to reply here for me enabling "Enables pointer lock options" worked fine on popOS!, didn't check yet on Arch

1 Kudo
Community Member

"Enables pointer lock options" doesn't change anything for me.

0 Kudos
Community Member
Same as everyone here. Stadia runs acceptable on windows but on Linux the input gag from mouse movement it just makes the game unplayable. I like playing FPS game like Destiny, Unreal Tournament and Fortnight using mouse and keyboard. The fixes suggested by @Mad_Dog_Brave do not work. They improved the situation for about 30 seconds of play and then the crazy mouse lagging kicked in again. I'm more frustrated then ever that it runs on Windows but not on Linux. It is just ridiculous. The hole point for me to try Stadia was to enjoy gaming in Linux.
1 Kudo
Community Member

Well, it's not a general Linux problem - it runs fine for a lot of people, including me on Linux Mint 19.2 Cinnamon + Chrome 79 stable. 

0 Kudos
Community Member

@Bogdan

For now, until Google gets their linux support in order, set the "Data usage & performance" to "Limited data usage". It was the only thing that helped me get rid of the extreme input lag on my linux setups.

0 Kudos
Community Member
If all else fails to reduce the extreme input lag (like it did for me) then do this: In the stadia app tap your avatar on the top right. Tap "Data usage & performance" Select "Limited data usage" (Yes this updates what happens on your pc as well) Looks a bit crappy with 720p on a 1440p monitor but at least the input lag is gone. I have no problem using "Best visual quality" when using the chromecast ultra, but on Ubuntu it's just not happening (same on several different setups) . At least I can play the games with the above settings.
1 Kudo
Community Member
Reducing the quality indeed makes it better and almost playable. But that's the thing: now the stream is light enough to be decoded fast enough under Linux, while the same stream under Windows is significantly faster decoded. Google has to tweak Linux Chrome. That was an important argument for Stadia, at least for me: ditch Windows gaming once and for all.
0 Kudos
Community Member
I use Ubuntu with an old and basic Nvidia Gforce. At first it does not work all right, I lost frames and the game had lag. I solved it by changing the drivers that were installed (x.org) by the owners of Nvidia, now it works perfect! With lag "0" it is instantaneous and very soft. I still do not have the command and tried it with a mouse and keyboard. I play high image quality.
0 Kudos
Community Member

Does anybody know the codec Google is using? VP9? The nVidia driver of my GTX 770 tells me in VDPAU info, that it is only capable of MPEG1, MPEG2, H264, VC1, MPEG4, DIVX4 and DIVX5.

0 Kudos
Community Member
Hello, I found a performance boost for my stadia experience on Manjaro Linux in chrome stable release by changing the cpu governor. To do so: Terminal: sudo cpupower frequency-set -g performance further information: https://wiki.archlinux.org/index.php/CPU_frequency_scaling The result was a lot better then with the stock setting on "schedutil". Btw I have an amd cpu so might be a bit different on intel cpus.
1 Kudo
Community Member
@Halbheld Stadia uses VP9 (and likely AV1 in the near future)
0 Kudos
Community Member
One possible solution is, to install a Chromium version with vaapi enabled (available as a snap). See https://www.omgubuntu.co.uk/2019/11/stadia-on-ubuntu-linux-mint The problem is, that you also need an extension (h264ify) to force Youtube to send out h264 videos instead of VP9. I don't think that this works with stadia. Has anyone any progress on this? Our solutions to minimize the stream or maximize the CPU power are okay, but the local graphics card should do its share.
0 Kudos
Community Member

Chrome on Linux does not support GPU acceleration yet unfortunately. I'd advise against using that Chromium with VAAPI enabled, it's a very old version with tons of security issues.

0 Kudos
Community Member

Hi, I'd like to share my experience.
I have a FTTH Internet connection running at 600 MBPS.
I connect all my devices with a 5GHz WiFi connection to it.
The Google Chromecast Ultra wih Stadia controller is working as a charm: optimal video quality, no input lag.
I tested Stadia un some DELL Laptops on the same network; they all have similar specs so hardware is not relevant.

But I tested different OSes:

- MS Windows + Google Chrome: optimal video quality, no input lag, both with keyboard and mouse and with USB connected Stadia Controller
- Ubuntu 18.04 with Google Chrome: optimal video quality; a big issue with input lag making Ghost Recon Breakpoint on Stadia; it is is present with keyboard+mouse but is more evident with Stadia Contrller

After some searches on the Internet it ended up that Google has no plans to support Hardware acceleration for video decoding for Chrome on Linux.
Every attempt to change Chrome flags related to hardware acceleration were useless.
I followed what explained here: https://www.linuxuprising.com/2018/08/how-to-enable-hardware-accelerated.htm: basically installing Chromium Browser pathced with Video hardware acceleration support (VAAPI) and everything is working fine:
Stadia set up with maximum quality, perfect video rendering and no input lag with K+M or Stadia controller.

Hope this can help.

0 Kudos
Community Member

Tried SteamOS yesterday. Installed chrome and feels like on windows. No lags, mouse movement as it should be.

1 Kudo