cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Game super laggy with mouse

I was playing Destiny 2 on Chrome on my laptop. If I didn't move at all, the graphics and frame rate of my game were good. But as soon as I used my USB mouse (Logitech G Pro) to look around, the game became super laggy and unplayable. I tried moving the mouse from one edge of the screen to the other in the title screen, and it was skipping bad.

However, when I tried using my trackpad to move or when I used the Stadia controller over USB, the game was good. Only when I moved my mouse were there serious issues. I never had any issues like this with my mouse before, it's always worked great.

Anyone else have this issue or have ideas on how to fix it? I think it's pretty strange and I'm not sure why it's having this issue. 

1 Kudo
7 Replies
Community Member

I had similar lag when using mouse on my laptop although to be fair it seemed to dissapear the longer I played. But I ended up plugging in an ethernet cable and it was instantly better. Experienced no lag and felt very smooth I was impressed.

0 Kudos
Community Member

Interesting, I should note my laptop was connected to Ethernet the whole time and I have a very good connection.
0 Kudos
Community Member

Solved using fresh install of developer version of Chrome

0 Kudos
Community Member

@drdinosaur 
worked for me!

0 Kudos
Community Member

Most likely incorrect flags have been set in Chrome.  Navigate to the URL chrome://flags/ then check that both the following are set to Enabled

  • Hardware-accelerated video decode
  • Hardware-accelerated video encode

If that doesn't address the issue, just click the Reset all to default button, restart Chrome and you should be in good order.

Kudos appreciated if deserved.
0 Kudos
Community Member

@Mad_Dog_Bravo Same issue here but both of those are already enabled for me. PUBG appears laggy and the mousemovements are uncomfortably laggy. 

0 Kudos
Stadia Player
Stadia Player

For me the better solution are 2 options:

1. Disable vsync in chrome browser 

https://community.stadia.com/t5/Stadia-on-Chrome/I-certainly-think-chrome-should-disable-Vsync-for-S...

2. Disable mouse acceleration in your OS

https://www.tomshardware.com/news/how-to-disable-mouse-acceleration-windows,36886.html

 

And reset all flags in chrome and update your chrome browser

0 Kudos