cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Poor streaming quality on Windows 10

Has anyone the same Problem that the streaming quality on windows 10 with the Stadia App / Chrome Browser is very poor even on "excellent" connection? On Chromcast it looks really good, on Windows unfortunately not.

Is there any solution to get a better quality on windows?

 

RDR2.png

0 Kudos
16 Replies
Stadia Guide
Stadia Guide

@EuReGiO What troubleshooting steps have you tried already? This page is a great place to start:

https://support.google.com/stadia/answer/9595943

0 Kudos
Community Member

@codesplicetried every step but quality still poor even i have a excellent connection.

0 Kudos
Community Member

What input method are you using ? When i try to use a keypad on a wireless connection it suffers terribly. However if i use a wired controller it works great. What quality setting have you chosen? Also what kind of connection are you using? If wireless.  What band? I also found issues with a proprietary ISP router switching from 5ghz to 2.4 causing a laundry list of issues .

0 Kudos
Community Member

@ShaneAnderson  I tried both input methods. Keyboard + Mouse and Stadia Controller. Quality Setting were on Max (4K) now down on Full HD but still same (only have Full HD Monitor). I only use a 5 GHz WLAN Connection on Laptop.

0 Kudos
Community Member

I use an old acer s3-391(2012 with i5) at first it was terrible . Works perfect now. Using gamepad. Still won't work smoothly with keyboard. So I'm sure there's hope for you as well. What does an Ookla sppedtest give you ? DL UL and ping? What chrome version are you running ? 

0 Kudos
Community Member

Also what type of router do you have? Is your router IP set to dynamic or static address? 

0 Kudos
Community Member

@ShaneAnderson

I have an i5 8th Gen CPU. Speedtest by Ookla down ist 133mbps and ping is 18ms. Shouldnt be because of my internet connection. I have a dedicated Graphic Card by Nvidia. Deactivated it that i only use the intel Graphic. I had some issues with input lags with Keyboard + Mouse but seems now solved after deactivate the dedicated graphic. Chrome Browser is the newest, did a check for update today. And i use a dynamic ip adress.

In my opinion i dont think that it has anything with my internet to do. More like an graphics or browser settings problem.

The connection on stadia is excellent, also no input lags with keyboard + mouse. Only problem that quality of graphic from game not like the graphic on chromcast like it should be.. It looks like you streaming a video in bad quality.

1 Kudo
Community Member

@EuReGiO re-enable the nVidia and try the following from this thread https://community.stadia.com/t5/Stadia-on-Chrome/Chrome-quality-issues/td-p/16232;

Go to your nvidia control panel --> Manage 3D- Settings --> Programm Settings --> Choose Google Chrome (chrome.exe) 
--> Power Managment Mode: Choose "Prefer Maximal Performance" --> Low Latency Mode: Choose "Ultra" --> save

Hopefully that helps, if it does please give the original poster Unrestrict (bottom of page 1) Kudos as deserved, good luck!

1 Kudo
Community Member

@SammyCunfortunately did not helped out. The Graphics Card MX130 which i have has not the "Low Latency Mode" setting. I played around with the settings in the Nvidia control panel, still no improvment.

I would stay at the Nvidia Graphics but due the input lag i had to change again to intel graphics. At least its playable with no latency problems.

But the problem still excists that the Graphic / Image is still not like in Chromcast.

PS: I played with the Intel Graphic settings but also no improvment of image qualitiy.

0 Kudos
Community Member

I don't know if this would help but I've read that Microsoft Windows 10 Game mode can cause problems with some games and hardware. I don't know how that affects Stadia but it might be worth a try. You can turn off game mode by doing the following:

To turn the mode off, open the Start Menu (Windows logo) and press the gear icon to open Settings. 

 

From there, click Gaming (Xbox logo) and choose Game Mode from the left-side panel. At the top, you'll see a slider. Make sure that slider is set to "Off." 

1 Kudo
Community Member

If you are still having this issue. Try right clicking on the chrome icon click properties , under full screen optimizations turn that off.  Make sure they are disabled. And let us know how you make out 🙂 cheers

1 Kudo
Community Member

Playing FFXV is an absolute blurry mess on Chrome but looks decent in CCU. If anyone finds a solution to lesser graphic fidelity on Chrome, I'm all for suggestions.

0 Kudos
Community Member

@Vinotauro Did you try my recommendation i posted above!?

0 Kudos
Community Member

@ShaneAnderson @Crowrezin Seems like quality is better than before, thanks guys. Back on Nvidia Graphics.

2 Kudos
Community Member

Has it improved since the update to use wireless controller with chrome? I noticed a big time improvement. While playing on my old laptop using my stadia controller wirelessly i had the best experience. No lag or stutter. 

0 Kudos
Community Member

Only play with Keyboard + Mouse on Laptop. Cant say anything.

0 Kudos