cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Nvidia RTX 2080 & Stadia & Chrome Issue Thread

I've been a Stadia Founder from the start. I've had nothing but great experience with Stadia on my Big Screen OLED TV, but my computer has had nothing but issues. This is from the start.. I have been on Stadia support since the beginning and they have been great, but clearly a small issue on my end. Want to say Thank you to their team, they have really good support!

To the issue... I built this computer right before Stadia launched. It has been nothing but problems. I have been debugging it for a year now and come to the conclusion there is issues with the RTX 2080 card, and drivers and perhaps its faulty hardware involved but need to narrow it down as I have seen others with RTX 2080's and the same issue.

So I make this thread to discuss the issues, troubleshooting done, and workarounds....

COMPLAINT. Stadia simply will not run on PC via Chrome without logging out after a minute... You start off with a green connection light.. after 10 seconds it goes yellow, then red.. finally disconnecting from game. This indicates a network issue, but in reality its not. I have replaced motherboards, cables, routers, rewired the house, and all kinds of things before narrowing the issue down. I finally hooked up my router to my phone and this gave some clues of being throttled, it simply showed it was always at 3 mbps (I'm on a gigabit connection testing at 900+ down and 900+ up)

As of the latest Nvidia drivers 7/4/2020, the app freezes when using the Stadia interface requiring a hard reboot..

Known facts.

1. Its definitely related to the video card, perhaps something to do with decoding as it throttles the network to 3mbps when using Stadia and having this bug.

2. Small chance it has to do with RTX 2080 and Intel i7 8700k CPU as all other people who I have seen experience this same issue seem to also have this CPU. But because its a common beast gaming CPU, It's not conclusive by any means this chip is any part of the issue.

After being on support with NVIDIA, a few tweaks to the 3D settings, and a drive hotfix from date of 7/24/2020 is available
Version 451.85 https://nvidia.custhelp.com/app/answers/detail/a_id/5046

(While i had success with this driver on live chat, 2 days later the issue came back to haunt me again... which is very odd... not sure how it could work one day then not the next.. unless I did not turn encoding back on like i thought or perhaps a computer reboot required the hardware encoding to kick in)

A solution is to type this in chrome
chrome://flags

Disable the following  two services:
Hardware-accelerated video decode
Hardware-accelerated video encode

Obviously you want to use your GPU to do this, but for us, its broken, so at least we can get around and play Stadia games.

As soon as you do this, your game will work fine, graphics will suffer because its using your CPU etc to decode the stream, but you have a good enough CPU so should be okay, just will see weird color issues  from time to time etc...

Nvidia gave me a few things to turn off by default but I forgot what those are, perhaps they can help, they don't affect any PC games, as the game itself will choose itself, but perhaps it helps Stadia players. If anyone has this settings from NVIDIA, please post, I have tried to recontact Nvidia, but for days now, i get no help in their live chat.

If you have any recommendations on how we can further troubleshoot to see if its a driver/hardware issue or some other bug, please comment.

Regards, Dr. Centz
1 Kudo
4 Replies
Community Member

n1.PNG

Reinstalled Chrome today, just to see if I could figure something out. Now even in incognito mode, and with encoder off, I am freezing if I hit escape locking my computer, requiring a reboot, menu is not as responsive, but the stream is green with the encoder disabled.

This tells me something, I am going to reinstall the drivers now... Makes no sense that it was fine before the reinstall of chrome and did not seize, this specifically is indicating its a Nvidia driver issue, gonna try two things, reinstall same driver first.. then go back in time and install an old driver

Update, while installing the same driver again, i noticed the GeForce Experience had a older version still installed. So somehow it only installed the
451.85 driver and not the 3.20.4.14 Geforce experience version, which is weird, I did not deselect that last night, this is probably causing the freezing I just experienced.

So the hotfix is driver has been updated for a couple new game fixes but the GeForce Experience has been downgraded to stop the seizing... LOL.
Another fix is to completely remove GeForce Experience, This will stop all the seizing. I have loved to use the clip capture tool, but for years now it has been an unreliable piece of crap tool, that when I go to hit alt-F10 to save that clip, its off for some reason...  Best off just record all your video and have a pen and pencil for time, and remove this crapware from your system. I am now going to see if GeForce Experience is the reason why Encoding dont work... I will update this message again if encoding on works, if no update, then its still a unkown bug why hardware encoding dont work.

Update, I'm back but with bad news, enabling the hw encoder again without GeForce Experience installed caused the system to throttle the network back to 3mbps and even the freezing happened when I hit ESC to exit. 😕 So don't bother trying this... waste of time.

Regards, Dr. Centz
0 Kudos
Community Member

Today, I tried using the black screen chrome bug fix, to see if I could get my encoder enabled and working... was a bad idea, the bug fix for the black screen was to go

into your %APPDATA% LOCAL google  chrome settings and delete the shader cache directory contents.... 

I did this, and now I am not running Geforce Experience at all and now crashing any time I hit ESC, no matter what driver version, whereas before i would only crash with the latest 3.20.4.14 version of geforce experience installed 😕

 

Regards, Dr. Centz
0 Kudos
Community Member

Been experimenting with monitor refresh rate, as I have a 240hz monitor. I moved it to 60hz, and so far the system is not hanging up requiring a hard reboot when I hold down ESC to get the Stadia App Interface menu to pop up from in game.. In short, Maybe this is part of the issue... I have not yet try turning back on encoding... will do that and also Nvidia's latest driver just came out... Trying it now, will report back any issues

Regards, Dr. Centz
0 Kudos
Community Member

Hello, it works with encoding on! Interface seems so much better, more responsive!!

I did update the drivers before attempting, so I am running the following...

Graphics Driver 452.06
Audio Driver 1.3.38.34
GeForce Exp 3.20.3.6
physx 9.19.0218
usbc 1.42.831.832

One final test! switching back to 120 & 240hz

240hz and Encoding on IS WORKING... I'm guessing the new drivers did all the work, it may be they finally added support for this 240HZ monitor, but I'd be surprised it wasn't already there being a Alienware model...

Anyhow, if the drivers are not working and you are in HZ over 60hz, first try going to 60hz, see if the freezing stops... 60hz trouble free gaming > 240hz freezing!

Consider this thread closed, unless something else happens

Regards, Dr. Centz
0 Kudos