cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Doom Eternal "your game had a glitch"

When selecting some missions, E.G. master levels or Bosses levels.

No problem with other missions and managed to complete the whole campaign.

Also, one milestone is not marked as achieved even thought it is.

@GraceFromGoogle 

93721323_1476301285881793_2435820951657512960_n.png

1 Kudo
4 Replies
Community Member

@ImTheDoctor 

Sounds like a broken feature in the game, raise a case via the publishers support forum is usually the first step that is recommended, follow that up with a case with Stadia support (although they tend to redirect game issues back to the publisher again from past experience). However, past performance from different publishers on issues of this nature have been pretty **bleep** slow imho.

Kudos appreciated if deserved.
0 Kudos
Community Member

@Mad_Dog_Bravo, @Bethesda has replied today to write to Google...

Anyway, in the meantime, I've made some new attempts, here are the details:

I've completed the campaign. Now, I wanted to replay some missions, just for fun.

Everything is fine if I select missions without a boss fight. In other cases what you see in the screenshot is what happens.

Basically, after the loading, the message "press [SPACE]" shows, I press space and the game crashes.

Specifically, it happens:

- If I select a mission with a boss: Final sin, Doom hunter base, arc complex and so on;
- If I select a master level;
- If I try to enter a Slayer gate (e.g.: was re-playing Exultia just fine, after having punched the nest of the Slayer gate, the bug happened).

Interesting things:

1) everything was working perfectly before playing the Urdak mission.
I'm sure because before venturing into that, I've tried playing the cultist base master level and
I've replayed the arc complex because I had a missing codex and it all worked just fine
2) I tried creating a new save game and loading the cultist base master level with the new save game and it worked
hence, master levels are not broken

So, it seems that the crashes happen after some point in the progress of the campaign?

 

0 Kudos
Community Member

having the same problem, load screen at 100 then press a to start then crsahes with game had a glitch error. also re playing a level. taras nabad in my case will not loa but tried hell on earth and worked no problem. 

0 Kudos
Community Member

I've seen on the Bethesda forum that other people are having the same issues on different platform (i.e.: xbox and PS4) so it's a game issue.

Bethesda tech support also confirmed this to me saying also that once you run into this issue you'll need to start a new campaign in order to play those missions even after they will have fixed the bug.

0 Kudos