cancel
Showing results for 
Search instead for 
Did you mean: 
eckwok
Community Member

Have good connection but unable to launch games

Jump to solution
Have tried to launch different games today but all failed saying "Connection not stable" Ran the Stadia Speedtest several times and the connection is Great every time. Never have this issue before - possibly problems with the Stadia server?
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Ivan Stadia Guide
Stadia Guide

@eckwok Could be your internet wasn't stable. So even thought it was fine during the speed test, it wasn't stable when you were trying to launch the game. Were you streaming/downloading other stuff at the time?

------------------------------------------------------------------------------------------
Please @mention when replying to me, so I can get notified

View solution in original post

0 Kudos
2 Replies
Highlighted
Ivan Stadia Guide
Stadia Guide

@eckwok Could be your internet wasn't stable. So even thought it was fine during the speed test, it wasn't stable when you were trying to launch the game. Were you streaming/downloading other stuff at the time?

------------------------------------------------------------------------------------------
Please @mention when replying to me, so I can get notified

View solution in original post

0 Kudos
Highlighted
eckwok
Community Member

Hi Ivan, 

Launched the games again today and it was all good! Yes could be the stability of my internet. 

Thanks for the help!

0 Kudos