cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
P1ayerOne
Community Member

Blurred and Pixelated ... Ugh!

I have Spectrum 200Mbs ISP (236dl . 12ul . 29-34ms ping. Using Ethernet (all Cat6) 

Let me start by saying firstly that I love this gaming service. I don't mean to b****, but I feel like I'm not getting what I've paid for.  

I have rdr2, Borderlands 3, rage 2, grid and I have claimed all the pro games as well.  I can't play any of them above limited (720p). When I try the balanced setting I get blurred and heavily pixelated images and my session will get cut off within 5 minutes every time.  

Turning off HDR hasn't made a difference.  Toggling hardware acceleration in chrome hasn't made a difference.  I get the same result whether I use a chrome browser or the stadia app on Windows 10.  Turning off location services hasn't made a difference.

As you can tell, I've been trying a plethora of suggestions and it's getting frustrating as hell. I've invested $150 into AAA games that I can't play above 2010 technology.  

I have been looking in the tech support discussions here and on Reddit but haven't found a solution.  I even had my ISP out here last week to exchange my router and verify service quality.  HELP!  PLEASE!  

 

 

 

 

 

 

 

 

 

0 Kudos
4 Replies
Highlighted
Aix
Community Member

I am right there with you. I have a 1Gb fiber connection with Metronet. Stadia support has done nothing but blame my ISP, my router, etc. I have had Metronet out twice. They've done everything they could on my end. I bought Google's Nest WiFi router and plugged into that. I sent Stadia support a traceroute to DNS.google (8.8.8.8). There was a ton of lag between my ISP's peering router and Google's in Equinix in Chicago. Every time I have Stadia quality issues, the traceroute shows the same thing. They "escalated" and sent me a bunch of router config info. My response was that Nest WiFi router has a Gaming Preferred mode that specifically claims to optimize Stadia. I would suggest running a traceroute to 8.8.8.8 to see where the problem is...
0 Kudos
Highlighted
ModernSavage
Community Member

Two things to try, if you have not already, would be to try to play on a PC while it is directly connected to the cable modem. If this fixes your issue then your issue is likely within your network (router config or something). If that does not fix your issue connect your PC to a VPN service while directly connected to the modem. If this fixes your issue the issue is more likely external to you, like a bad route or ISP throttling.

1 Kudo
Highlighted
C0DEMAN
Community Member

I also have Metronet and in the midwest and Stadia. I am also having problems with the Stadia service. Metronet told me that they were having compatibility issues with Chicago's Equinix servers. And that Stadia runs off of them.
0 Kudos
Highlighted
C0DEMAN
Community Member

Also proof in the pudding:


Here is a world wide google data center ping test.  If your **bleep** is greater then 50 then your **bleep** is majorly **bleep**ed.

 

http://www.gcping.com/

 

PS Google does not want you to know about that website

0 Kudos