cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Poor performance ONLY on Destiny 2

Hey, so after going for over 48h through Google's chat support and Twitter support I came to the conclusion there appears to be no solution for my problem as of now. Basically, when I launch Destiny my experience is as follows:

https://www.youtube.com/watch?v=90lGlUTy-sk&feature=youtu.be

At the 0:38 mark more or less, the quality degrades and the framerate goes below what should be qualified as "playable" for a first-person shooter like Destiny. Here's some information if someone wants to think it through:

  1. I've been using Stadia since November 21 with NO issues before this. I started having this issue on December 8th 17.00 CET approximately.
  2. The poor performance issues is present both on Chrome browser and Chromecast.
  3. It is ONLY Destiny 2. Tomb Raider, Samurai Showdown and Farming Simulator run FLAWLESSLY at max resolution/framerate on both devices.
  4. 300Mbps symmetric fiber connection at home.
  5. Router DNS settings have been changed for Google's (8.8.8.8 Primary, 8.8.4.4 Secondary) and TCP/UDP ports 44700-44899 have been opened.
  6. No VPN whatsoever or anything that could interfere with the connection. 
  7. JavaScript is enabled on the Google Chrome browser.
  8. Chrome Flag "Hardware-Acceleration Video Encoding" is enabled.
  9. I can use other streaming services such as PSNow without ANY issue at all. 
  10. Geolocation is Spain.

So, with all this information here's my theory:

  • There's one machine running Destiny 2 in my closest datacenter that has performance issues.
  • For some reason, I'm assigned to this machine everytime. According to the support it's supposed to assing me to the best available machine nearby whenever I launch a game. However, they CAN'T manually assign me another machine, so there's no way to prove this as for now.
  • Other machines are running other games, thus that's why I have no issues with other games.
  • Everyone else is running Destiny 2 just fine, so it's not Bungie's or the game itself's issue. It is clearly coming from Stadia's Datacenter.

Any more information, comments, people having same issue, possible solutions. Feel free to jump in the discussion. Cheers.

0 Kudos
14 Replies
Community Member

So after further investigating, this somehow appears to be an account-specific issue.

https://www.youtube.com/watch?v=sqYfVnYku8Y&feature=youtu.be

My account (first account) runs Destiny 2 poorly. Switching accounts, Destiny 2 is able to run smoothly. 

Anyone can shed a bit of light on this matter? I can't do anything about it and Google Support appears to not be able to either.

0 Kudos
Community Member

Just to add extra information, I have this exact same issue on a different network/setup. Upon logging my Stadia account from a different location and launching Destiny 2, it runs poorly. Changing NOTHING BUT the account, makes Destiny 2 run smoothly. Clearly my account is assigned to a specific Stadia machine that is malfunctioning.
0 Kudos
Stadia Guide
Stadia Guide

Well it seems like you have tried everything already, but if it really is a Stadia-database"machine" and only exists with your Google account, we are not be able to help you either. So if the Stadia support can't too, who else should be able to help in this case? 🤔

Maybe it's worth in this case to try and contact the support again as they might be that your support-team-member was either not very good or the only other thing you could do is leaving feedback for the developers in stadia.google.com or the Stadia app.

0 Kudos
Community Member

Hoping to bring some light to the issue @Chufu, see if someone either: 1) Comes up with a magic solution I haven't tried yet. 2) Has the same issue and we can troubleshoot it somehow. 3) Works at Google and finds out I'm #1 Unlucky Stadia User and I have a unique problem. Hopefully will get a fix for it soon!
0 Kudos
Community Member

I feel for you and I hope your issue gets resolved quickly. This is however very interesting and it would be great if you could report back as soon as you get some qualified answer about what happened.

We know very little about Stadia infrastructure, abd I can't believe that a user is assigned to a single instance for any given game. Very curious...

0 Kudos
Community Member

@cynic :

It is quite a common practice, think of it a bit like DHCP lease, where a particular amount of time is assigned to your PC being given the same IP address from a dynamic list of addresses.  After the lease time has expired then you may receive a different IP address when a DHCP request is made to the pool of available addresses.

I would not be surprised if a similar approach would be employed by Stadia otherwise there is an added overhead to establish a new connection to a new cluster of servers each time that a user decides to reconnect.

Kudos appreciated if deserved.
0 Kudos
Community Member

I'm having the exact same experience as you and tried most of the things you mentioned. Any new updates? I was going to try support again after work today with the information I got now.
0 Kudos
Community Member

@Vanquished let me know if there any tests I can try on my end. Only difference I know that I did from friends is played on computer and mobile as well.

0 Kudos
Community Member

I am having exact same issue with 1Ggbps connection.

 

I contacted stadia we went through all this and more just to find out my boyfriends account works ok on same devices, so this is completely account related. I also posted this thread on bungie forums to see if we can get any help.

THIS UTTERLY SUCKS.

https://www.bungie.net/en/Forums/Post/254761630

0 Kudos
Community Member

I plan on contacting more this week. With more people having the problem, we may get actual help.
0 Kudos
Community Member

Are you using PC, or Chromecast Ultra?

Regards, Dr. Centz
0 Kudos
Community Member

This seems to have been fixed at least for me after I posted about this on bungie forums. Hope you had it fixed too. Regards,
0 Kudos
Community Member

Spoiler
EXACT same issue

I actually noticed that the lag only started happening after I enabled crosssave on Bungie so i can play the same character on steam. Did you happen to do that? Another data point is, when i play the same character on steam I do not have this lag, so it is not bungie's problem I suppose.

0 Kudos
Community Member

OK after I logged into my steam game, and changed my vsync back to 144hz, the game runs fine now...

0 Kudos